Σάββατο, 15 Μαΐου 2010

Άσκηση μετατροπής Όσο..επανάλαβε σε α) Για..από..μέχρι και β) Μέχρις_ότου

Αντικαταστήστε την εντολή Όσο που ακολουθεί:
            Χ  <-- 0
            Διάβασε μ
            ν <-- 28
            Όσο ν <= μ επανάλαβε
                  Χ <-- Χ+ν
                  ν <-- ν+3
            Τέλος_επανάληψης
με μια  
     α) Γιά..από..μέχρι
     β) Μέχρις_ότου
έτσι ώστε να προκύπτει το ίδιο αλγοριθμικό αποτέλεσμα

Λύση

       α)
            Χ  <-- 0

            Διάβασε μ
            Για ν από 28 μέχρι μ με_βήμα 3
                 Χ <-- Χ+ν
            Τέλος_επανάληψης
   
       β)
            Χ  <-- 0

            Διάβασε μ
            ν <-- 28
            Αν ν <=μ τότε
                Αρχή_επανάληψης

                    Χ <-- Χ+ν
                    ν <-- ν+3
                Μέχρις_ότου ν > μ
            Τέλος_αν

           

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου