Δευτέρα, 17 Μαΐου 2010

Άσκηση : μετατροπή συνάρτησης σε διαδικασία

Μετατρέψτε την παρακάτω συνάρτηση σε διαδικασία
    ΣΥΝΑΡΤΗΣΗ ΜΕΤ(α, β) : ΠΡΑΓΜΑΤΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: α
        ΠΡΑΓΜΑΤΙΚΕΣ: β, γ
    ΑΡΧΗ
        γ <-- α*β
        Αν γ > 123.7 τότε
              ΜΕΤ <-- γ+0.8
        αλλιώς
              ΜΕΤ <-- γ-0.2
        Τέλος_αν
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Λύση

    ΔΙΑΔΙΚΑΣΙΑ ΜΕΤ(α, β, απ)
    ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: α
        ΠΡΑΓΜΑΤΙΚΕΣ: β, γ, απ
    ΑΡΧΗ
        γ <-- α*β
        ΑΝ γ > 123.7 ΤΟΤΕ
              απ <-- γ+0.8
        ΑΛΛΙΩΣ
              απ <-- γ-0.2
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου