Τρίτη, 25 Μαΐου 2010

Άσκηση : Μενού λειτουργιών

Γράψτε πρόγραμμα το οποίο παρέχει το ακόλουθο
μενού λειτουργιών:
   1. Υπολογισμός α+β-γ
   2. Υπολογισμός 3(α+β)+γ
   3. Υπολογισμός 2α+4(β-γ)
   4. Έξοδος
Αν η επιλογή του χρήστη είναι 1 ή 2 ή 3 τότε:
* διαβάζονται τρεις πραγματικοί αριθμοί α, β, γ
* υπολογίζεται η αντίστοιχη παράσταση,
* εμφανίζεται στην οθόνη το αποτέλεσμα.
Αν η επιλογή είναι 4 (και μόνο τότε) το πρόγραμμα
τερματίζεται και εμφανίζεται το μήνυμα
    Τερματισμός λειτουργιών προγράμματος
Παρατήρηση : Πρέπει να διασφαλίζεται η εγκυρότητα
της επιλογής του χρήστη.

Λύση

    ΠΡΟΓΡΑΜΜΑ Μενού_λειτουργιών
    ΜΕΤΑΒΛΗΤΕΣ
         ΑΚΕΡΑΙΕΣ: Προτίμηση
         ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, Αποτέλεσμα
    ΑΡΧΗ
         ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΓΡΑΨΕ '1. Υπολογισμός α+β-γ'
              ΓΡΑΨΕ '2. Υπολογισμός 3(α+β)+γ'
              ΓΡΑΨΕ '3. Υπολογισμός 2α+4(β-γ)'
              ΓΡΑΨΕ '4. Έξοδος'
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΓΡΑΨΕ 'Δώσε την προτίμηση σου (1-4) :'
                    ΔΙΑΒΑΣΕ Προτίμηση
              ΜΕΧΡΙΣ_ΟΤΟΥ (Προτίμηση >= 1) ΚΑΙ 
                                          (Προτίμηση <= 4)
              ΑΝ Προτίμηση = 1 ΤΟΤΕ
                   ΔΙΑΒΑΣΕ α, β, γ
                   Αποτέλεσμα <-- α+β-γ
                   ΓΡΑΨΕ Αποτέλεσμα
               ΑΛΛΙΩΣ_ΑΝ Προτίμηση = 2 ΤΟΤΕ
                   ΔΙΑΒΑΣΕ α, β, γ
                   Αποτέλεσμα <-- 3*(α+β)+γ
                   ΓΡΑΨΕ Αποτέλεσμα         
              ΑΛΛΙΩΣ_ΑΝ Προτίμηση = 3 ΤΟΤΕ
                   ΔΙΑΒΑΣΕ α, β, γ
                   Αποτέλεσμα <-- 2*α+4*(β-γ)
                   ΓΡΑΨΕ Αποτέλεσμα               
              ΑΛΛΙΩΣ
                   ΓΡΑΨΕ 'Τερματισμός λειτουργιών προγράμματος'
              ΤΕΛΟΣ_ΑΝ
         ΜΕΧΡΙΣ_ΟΤΟΥ Προτίμηση = 4
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου