Τετάρτη, 19 Μαΐου 2010

Άσκηση : Επεξεργασία σε συγκεκριμένη γραμμή και στήλη

Ας θεωρήσουμε τον πίνακα ΒΑΘΜΟΙ[58, 6] που περιέχει
τους βαθμούς που συγκέντρωσαν οι 58 μαθητές της Γ΄τάξης
ενός γενικού λυκείου στα 6 πανελλαδικώς εξεταζόμενα
μαθήματα. Γράψτε αλγόριθμο, που με δεδομένο τον παραπάνω
πίνακα,υπολογίζει και εμφανίζει:
α) το μέσο όρο βαθμολογίας του 17ου μαθητή,
β) το ποσοστό (%) των μαθητών που έγραψαν τουλάχιστον
    80 στο 6ο μάθημα.

Λύση

    Αλγόριθμος ΠΑΝΕΛ
    Δεδομένα // ΒΑΘΜΟΙ //
    σ <-- 0
    Για λ από 1 μέχρι 6
         σ <-- σ+ΒΑΘΜΟΙ[17, λ]
    Τέλος_επανάληψης
    Μέσος <-- σ/6
    Γράψε Μέσος
    Πλήθος <-- 0
    Για λ από 1 μέχρι 58
         Αν ΒΑΘΜΟΙ[λ, 6] >= 80 τότε
               Πλήθος <-- Πλήθος+1
         Τέλος_αν
    Τέλος_επανάληψης
    Ποσοστό <-- 100*Πλήθος/58
    Γράψε Ποσοστό
    Τέλος ΠΑΝΕΛ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου