Τρίτη, 1 Ιουνίου 2010

Άσκηση : άθροισμα επιλεγμένων στοιχείων πίνακα

Γράψτε πρόγραμμα το οποίο:
α) διαβάζει 24 ακέραιες τιμές και τις καταχωρεί
     στήλη-στήλη στον πίνακα Υ[4, 6]
β) υπολογίζει και εμφανίζει το άθροισμα των
    στοιχείων του πίνακα που ανήκουν σε ζυγές
    γραμμές και μονές στήλες.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΑΘΡΠ
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: λ, μ, Υ[4, 6], Α
     ΑΡΧΗ
          ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 6
               ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 4
                     ΔΙΑΒΑΣΕ Υ[λ, μ]
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Α <-- 0
          ΓΙΑ λ ΑΠΟ 2 ΜΕΧΡΙ 4 ΜΕ_ΒΗΜΑ 2
               ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 2
                     Α <-- Α+Υ[λ, μ]
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ Α
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου