Σάββατο, 26 Ιουνίου 2010

Μετατροπές στη φυσσαλίδα

Ας θεωρήσουμε ένα ακέραιο πίνακα Δ[Μ].Γράψτε τη μέθοδο
ευθείας ανταλλαγής (φυσσαλίδα) αντικαθιστώντας:
α) Την εξωτερική Για..από..μέχρι με Όσο
β) Την εσωτερική Για..από..μέχρι με Μέχρις_ότου
γ) Την Αντιμετάθεσε με εντολές εκχώρησης
Παρατήρηση : Η σειρά της ταξινόμησης είναι φθίνουσα.

Λύση

    i <-- 2
    Όσο i <= Μ επανάλαβε
        j <-- M
        Αρχή_επανάληψης
              Αν Δ[j-1] < Δ[j] τότε
                  TEMP <-- Δ[j-1]
                  Δ[j-1] <-- Δ[j]
                  Δ[j] <-- TEMP
              Τέλος_αν
              j <-- j-1
        Μέχρις_ότου   j < i
        i <-- i+1
    Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου