Σάββατο, 12 Ιουνίου 2010

Άσκηση : λογικό διάγραμμα (Αν..τότε..αλλιώς_αν+Αν..τότε..αλλιώς)

Κατασκευάστε το λογικό διάγραμμα του παρακάτω
αλγορίθμου
    Αλγόριθμος ΑΣΚ
    Διάβασε μ, ν, ρ
    Αν μ > ν τότε
          Αν μ-ν > 5 τότε
               Α <-- ρ
          αλλιώς
               Α <-- ρ+1
          Τέλος_αν
    αλλιώς_αν μ < ν τότε
          Αν ν-μ > 2 τότε
               Α <-- μ+ρ
          αλλιώς
               Α <-- μ-ρ
          Τέλος_αν
    αλλιώς
          Α <-- ν+ρ
    Τέλος_αν
    Εμφάνισε Α
    Τέλος ΑΣΚ

Λύση

 

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου