Παρασκευή, 25 Ιουνίου 2010

Άσκηση μετατροπής Αν..τότε σε α) εμφωλευμένες Αν..τότε..αλλιώς β) Αν..τότε..αλλιώς_αν

Ξαναγράψτε με ισοδύναμο τρόπο το παρακάτω σύνολο
εντολών
     Αν μ > 5 τότε
         λ <-- μ+1
     Τέλος_αν
     Αν  (μ <=5) ΚΑΙ (μ > 2) τότε
         λ <-- μ-1
     Τέλος_αν
     Αν (μ <= 2) ΚΑΙ (μ >= 0) τότε
         λ <-- 2*μ
     Τέλος_αν
     Αν μ < 0 τότε
         λ <-- μ^2
     Τέλος_αν
χρησιμοποιώντας:
α) εμφωλευμένες Αν..τότε..αλλιώς
β) την Αν..τότε..αλλιώς_αν

Λύση

α)
     Αν μ > 5 τότε
         λ <-- μ+1
     αλλιώς
         Αν  μ > 2 τότε
              λ <-- μ-1
         αλλιώς
               Αν μ >= 0 τότε
                    λ <-- 2*μ
               αλλιώς
                    λ <-- μ^2
               Τέλος_αν
         Τέλος_αν
     Τέλος_αν


β)
     Αν μ > 5 τότε
         λ <-- μ+1
     αλλιώς_αν μ > 2 τότε
         λ <-- μ-1
     αλλιώς_αν μ >= 0 τότε
         λ <-- 2*μ

     αλλιώς
         λ <-- μ^2
     Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου