Πέμπτη, 10 Ιουνίου 2010

Άσκηση: Επεξεργασία δοσμένου πλήθους δεδομένων

Ένας διατροφολόγος κάνει μια έρευνα ανάμεσα στα
80 αγόρια - μαθητές της Γ' τάξης ενός ημερήσιου γενικού
λυκείου, προκειμένου να εντοπίσει πιθανές διαταραχές
βάρους. Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) Διαβάζει την κατώτατη (ΚΑΤΩ) και την ανώτατη
    (ΑΝΩ) τιμή που μπορεί να έχει το βάρος ενός
    αγοριού προκειμένου να κυμαίνεται σε φυσιολογικά
    επίπεδα (πρέπει να διασφαλίζεται η εγκυρότητα
    των εισερχόμενων δεδομένων).
β) Διαβάζει το βάρος των 80 αγοριών - μαθητών
    (δεν απαιτείται έλεγχος εγκυρότητας).
γ) Υπολογίζει και εμφανίζει:
     * το πλήθος των αγοριών που είναι υπέρβαρα,
     * το ποσοστό (%) των αγοριών που είναι ελλει-
        ποβαρή,
     * το μέσο όρο βάρους των αγοριών που κινούνται
       σε φυσιολογικά επίπεδα.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΕΡΕΥΝΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: λ, Υπ, Ελ, Φ
            ΠΡΑΓΜΑΤΙΚΕΣ: ΚΑΤΩ, ΑΝΩ, ΠΟΣ,
                                           ΑΘΡ, ΜΒ, Β
      ΑΡΧΗ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  ΔΙΑΒΑΣΕ ΚΑΤΩ, ΑΝΩ
            ΜΕΧΡΙΣ_ΟΤΟΥ (ΚΑΤΩ > 0) ΚΑΙ (ΑΝΩ > 0)
                                      ΚΑΙ (ΚΑΤΩ < ΑΝΩ)
            Υπ <-- 0
            Ελ <-- 0
            Φ <-- 0
            ΑΘΡ <-- 0
            ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 80
                    ΔΙΑΒΑΣΕ Β
                    ΑΝ Β > ΑΝΩ ΤΟΤΕ
                           Υπ <-- Υπ+1
                    ΑΛΛΙΩΣ_ΑΝ Β < ΚΑΤΩ ΤΟΤΕ
                           Ελ <-- Ελ+1
                    ΑΛΛΙΩΣ
                           Φ <-- Φ+1
                           ΑΘΡ <-- ΑΘΡ+Β
                    ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΓΡΑΨΕ 'Πλήθος υπέρβαρων αγοριών :', Υπ
             ΑΝ Ελ > 0 ΤΟΤΕ
                    ΠΟΣ <-- 100*Ελ/80
                    ΓΡΑΨΕ 'Ποσοστό ελλειποβαρών = ', ΠΟΣ
             ΑΛΛΙΩΣ
                    ΓΡΑΨΕ 'Δεν υπάρχει κανένας ελλειποβαρής'
             ΤΕΛΟΣ_ΑΝ
             ΑΝ Φ > 0 ΤΟΤΕ
                    ΜΒ <-- ΑΘΡ/Φ
                    ΓΡΑΨΕ 'ΜΟ βάρους φυσιολογικών = ', ΜΒ
             ΑΛΛΙΩΣ
                    ΓΡΑΨΕ 'Δεν υπάρχει κανένα αγόρι με'
                    ΓΡΑΨΕ 'φυσιολογικό βάρος'
             ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου