Τετάρτη, 16 Ιουνίου 2010

Αποτελέσματα VS Γράψε

Κατ΄ αρχήν να ξεκαθαρίσουμε ότι η χρήση της
δήλωσης Αποτελέσματα είναι δυνατή μόνο στους αλγορίθμους
και όχι στα προγράμματα όπου χρησιμοποιούμε μόνο την
εντολή εξόδου ΓΡΑΨΕ.
Η δήλωση Αποτελέσματα  χρησιμοποιείται μόνο όταν στην
εκφώνηση του  αλγορίθμου αναφέρεται :
    ... που υπολογίζει ....
Από την άλλη μεριά, αν στην εκφώνηση της άσκησης
εμπεριέχονται εκφράσεις όπως:
    ... υπολογίζει και τυπώνει...
    ... υπολογίζει και εμφανίζει....
πρέπει να χρησιμοποιηθεί η εντολή Γράψε.
ΠΑΡΑΤΗΡΗΣΗ : Ανεξάρτητα από την εκφώνηση,
σε ένα πρόγραμμα χρησιμοποιούμε πάντοτε και
μόνο την εντολή ΓΡΑΨΕ για την έξοδο
των αποτελεσμάτων.

Παράδειγμα

Εκφώνηση 1η : Γράψτε αλγόριθμο που διαβάζει
τα υψη δύο μαθητών και υπολογίζει  το μικρότερο
ύψος.

       Αλγόριθμος Εκφ1
       Διάβασε Υ1, Υ2
       ΜΙΝ <-- Υ1
       Αν Υ2 < ΜΙΝ τότε
           ΜΙΝ <-- Υ2
       Τέλος_αν
       Αποτελέσματα // ΜΙΝ //
       Τέλος Εκφ1

Εκφώνηση 2η : Γράψτε αλγόριθμο που διαβάζει
τα υψη δύο μαθητών, υπολογίζει  και εμφανίζει
το μικρότερο  ύψος.

       Αλγόριθμος Εκφ2
       Διάβασε Υ1, Υ2
       ΜΙΝ <-- Υ1
       Αν Υ2 < ΜΙΝ τότε
           ΜΙΝ <-- Υ2
       Τέλος_αν
       Γράψε ΜΙΝ
       Τέλος Εκφ2

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου