Τρίτη, 8 Ιουνίου 2010

Άσκηση : βήμα-βήμα εκτέλεση (με υποπρογράμματα)

Ποιά είναι η έξοδος του παρακάτω προγράμματος;
     ΠΡΟΓΡΑΜΜΑ ΑΣΚ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: α, β, μ
           ΠΡΑΓΜΑΤΙΚΕΣ: ρ
     ΑΡΧΗ
           α <-- 4
           β <-- 12
           μ <-- α mod β+1
           ΓΙΑ χ ΑΠΟ α-2 ΜΕΧΡΙ μ ΜΕ_ΒΗΜΑ  μ-3
                 ΚΑΛΕΣΕ Δ(α, β, ρ)
                 ΓΡΑΨΕ α, β, ρ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΡΑΨΕ χ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

     ΔΙΑΔΙΚΑΣΙΑ Δ(μ, ν, κ)
     ΣΤΑΘΕΡΕΣ
            α = 1.8
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: μ, ν
            ΠΡΑΓΜΑΤΙΚΕΣ: κ
     ΑΡΧΗ
            μ <-- μ+5
            ν <-- ν+3
            κ <-- Α_Τ(μ-ν)+α
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Λύση

     α = 4
     β = 12
     μ = α mod β+1 = 4 mod 12 + 1 =4+1 = 5
     Η ΓΙΑ εκτελείται για όλες τις τιμές του χ από
    α-2 = 4-2 = 2 μέχρι 5 με βήμα μ-3 = 5-3 = 2.
    1η επανάληψη (χ = 2)
          Κλήση της Δ με μ = α = 4, ν = β = 12, 
                              κ = ρ = απροσδιόριστο
                 μ = μ+5 = 4+5 = 9
                 ν = ν+3 = 12+3 = 15
                 κ = Α_Τ(μ-ν)+α = Α_Τ(9-15)+1.8 = Α_Τ(-6)+1.8
                    = 6+1.8 = 7.8
          Μετά την ολοκλήρωση της διαδικασίας οι τιμές των
          μεταβλητών είναι :
                α = μ = 9
                β = ν = 15
                ρ = κ = 7.8
          Η ΓΡΑΨΕ εμφανίζει:
                9     15     7.8
     2η επανάληψη (χ = 4)
          Κλήση της Δ με μ = α = 9, ν = β = 15, κ = ρ = 7.8
                 μ = μ+5 = 9+5 = 14
                 ν = ν+3 = 15+3 = 18
                 κ = Α_Τ(μ-ν)+α = Α_Τ(14-18)+1.8 = Α_Τ(-4)+1.8
                    = 4+1.8 = 5.8
          Μετά την ολοκλήρωση της διαδικασίας οι τιμές των
          μεταβλητών είναι :
                α = μ = 14
                β = ν = 18
                ρ = κ = 5.8
          Η ΓΡΑΨΕ εμφανίζει:
                14     18     5.8
      Η ΓΙΑ τερματίζεται με χ = 6.
      Η ΓΡΑΨΕ εμφανίζει:   6

1 σχόλιο:

  1. Πολύ καλή η προσπάθεια σου με ένα blog για την ΑΕΠΠ που ανανεώνεται τακτικά.

    ΑπάντησηΔιαγραφή