Σάββατο, 5 Ιουνίου 2010

Άσκηση : Κατασκευή λογικού διαγράμματος (Όσο+Αν..τότε..αλλιώς)

Κατασκευάστε το λογικό διάγραμμα του παρακάτω
αλγόριθμου
      Αλγόριθμος ΑΣΚ
      α <-- 3
      Όσο α < 71 επανάλαβε
            Διάβασε β
            Αν β > 0 τότε
                 γ <-- α^β
            αλλιώς
                 γ <-- α*β
            Τέλος_αν
            α <-- α+6
      Τέλος_επανάληψης
      γ <-- γ+1
      Εμφάνισε γ
      Τέλος ΑΣΚ

Λύση




   

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου