Παρασκευή, 4 Ιουνίου 2010

Άσκηση: Πρόγραμμα+συνάρτηση

Ι. Γράψτε πρόγραμμα το οποίο:
    α) διαβάζει 20 ακέραιους αριθμούς,
    β)  καλώντας κατάλληλη συνάρτηση, ελέγχει για τον
         καθένα από αυτούς αν  είναι πολλαπλάσιο τόσο του
        4 όσο και του 12,
    γ) υπολογίζει και εμφανίζει:
        * το ποσοστό των αριθμών που είναι πολλαπλάσια
           τόσο του 4 όσο και του 12,
        * το μέσο όρο των αρνητικών αριθμών.
ΙΙ. Να γράψετε τη συνάρτηση που καλεί το πρόγραμμα
     στο ερώτημα  Ι-β).

Λύση

      ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: μ, Χ, φ, Σύνολο, Αρνητικοί
            ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΣΤΟ, ΜΟΑρν
      ΑΡΧΗ
            φ <-- 0
            Σύνολο <-- 0
            Αρνητικοί <-- 0
            ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 20
                  ΔΙΑΒΑΣΕ Χ
                  ΑΝ Τσέκαρε(Χ) = ΑΛΗΘΗΣ ΤΟΤΕ
                        φ <-- φ+1
                  ΤΕΛΟΣ_ΑΝ
                  ΑΝ Χ < 0 ΤΟΤΕ
                        Αρνητικοί <-- Αρνητικοί+1
                        Σύνολο <-- Σύνολο+Χ
                  ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΠΟΣΟΣΤΟ <-- 100*φ/20
            ΓΡΑΨΕ ΠΟΣΟΣΤΟ
            ΑΝ Αρνητικοί > 0 ΤΟΤΕ
                  ΜΟΑρν <-- Σύνολο/Αρνητικοί
                  ΓΡΑΨΕ ΜΟΑρν
            ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Δεν υπάρχουν καθόλου αρνητικοί!'
            ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

      ΣΥΝΑΡΤΗΣΗ Τσέκαρε(Χ) : ΛΟΓΙΚΗ 
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Χ
      ΑΡΧΗ
             ΑΝ MOD 4 = 0) KAI (X MOD 12 = 0) TOTE
                   Τσέκαρε <-- ΑΛΗΘΗΣ
             ΑΛΛΙΩΣ
                   Τσέκαρε <-- ΨΕΥΔΗΣ

             ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου