Τρίτη, 22 Ιουνίου 2010

Άσκηση μετατροπής Αν..τότε..αλλιώς_αν σε α) εμφωλευμένες Αν..τότε..αλλιώς β) Αν..τότε

Ξαναγράψτε (ισοδύναμα) το παρακάτω σύνολο εντολών
      Αν  β = 1 τότε
           Εμφάνισε 'Γ τάξη'
      αλλιώς_αν (β = 3) Ή (β = 18) τότε
           Εμφάνισε 'Ημερήσιου'
      αλλιώς_αν (β = -8) Ή (β = 0) Ή (β = 71) τότε
           Εμφάνισε 'Γενικού'
      αλλιώς
           Εμφάνισε 'Λυκείου'
      Τέλος_αν
χρησιμοποιώντας:
α) εμφωλευμένες Αν..τότε..αλλιώς
β) εντολές Αν..τότε

Λύση

    α)
          Αν  β = 1 τότε
              Εμφάνισε 'Γ τάξη'
          αλλιώς
               Αν (β = 3) Ή (β = 18) τότε
                   Εμφάνισε 'Ημερήσιου'
               αλλιώς
                      Αν (β = -8) Ή (β = 0) Ή (β = 71) τότε
                           Εμφάνισε 'Γενικού'
                      αλλιώς
                           Εμφάνισε 'Λυκείου'
                      Τέλος_αν
               Τέλος_αν
           Τέλος_αν


     β)
           Αν β = 1 τότε
                 Εμφάνισε 'Γ τάξη'
           Τέλος_αν
           Αν (β = 3) Ή (β = 18) τότε
                 Εμφάνισε 'Ημερήσιου'
           Τέλος_αν
           Αν (β = -8) Ή (β = 0) Ή (β = 71) τότε
                 Εμφάνισε 'Γενικού'
           Τέλος_αν
           Αν (β < > 1) ΚΑΙ (β < > 3) ΚΑΙ (β < > 18) ΚΑΙ
                (β < > -8) ΚΑΙ (β < > 0) ΚΑΙ (β < > 71) τότε
                 Εμφάνισε 'Λυκείου'
           Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου