Σάββατο, 26 Ιουνίου 2010

Διορθώστε τα λάθη

Ας θεωρήσουμε την παρακάτω, λανθασμένη, συνάρτηση:
    ΣΥΝΑΡΤΗΣΗ  ΑΡΧ(κ, λ) : ΠΡΑΓΜΑΤΙΚΕΣ
    ΣΤΑΘΕΡΕΣ
          μ <-- 3.2
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: κ
          ΠΡΑΓΜΑΤΙΚΕΣ: λ
    ΑΡΧΗ
          ΑΡΧ <-- μ
          ΑΝ λ > κ ΤΟΤΕ
              ΑΡΧ <-- ΑΡΧ+(λ-κ)
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣΣΥΝΑΡΤΗΣΗΣ
Διορθώστε τα λάθη και ξαναγράψτε τη συνάρτηση από
την αρχή.

Απάντηση

    ΣΥΝΑΡΤΗΣΗ  ΑΡΧ(κ, λ) : ΠΡΑΓΜΑΤΙΚΗ
    ΣΤΑΘΕΡΕΣ
          μ = 3.2
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: κ
          ΠΡΑΓΜΑΤΙΚΕΣ: λ, ΤΕΜΡ
    ΑΡΧΗ
          ΤΕΜΡ <-- μ
          ΑΝ λ > κ ΤΟΤΕ
              ΤΕΜΡ <-- ΤΕΜΡ+(λ-κ)
          ΤΕΛΟΣ_ΑΝ
          ΑΡΧ <-- ΤΕΜΡ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
      

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου