Σάββατο, 19 Ιουνίου 2010

Άσκηση : Γέμισμα δυσδιάστατου πίνακα

Γράψτε αλγόριθμο που γεμίζει τον πίνακα Μ[7, 7] ως
εξής:
* στα στοιχεία των δύο κυρίων διαγωνίων εκχωρεί την
   τιμή -1,
* σε όλα τα υπόλοιπα στοιχεία εκχωρεί την τιμή 11.

Λύση

     Αλγόριθμος Γέμισμα
     Για λ από 1 μέχρι 7
         Για ρ από 1 μέχρι 7
             Αν (λ = ρ) Ή (λ+ρ = 8) τότε
                  Μ[λ, ρ] <-- -1
             αλλιώς
                  Μ[λ, ρ] <-- 11
             Τέλος_αν
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Αποτελέσματα // Μ //
     Τέλος Γέμισμα

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου