Κυριακή, 13 Ιουνίου 2010

Άσκηση : λογικό διάγραμμα (εμφωλευμένες δομές επιλογής)

Γράψτε τον αλγόριθμο σε ψευδογλώσσα που αντιστοιχεί
στο παρακάτω λογικό διάγραμμα

 



















Λύση

     Αλγόριθμος ΑΣΚ
     Διάβασε ν, x, z
     Αν ν > 7 τότε
         Αν x < 0 τότε
              Αν z > 0 τότε
                   Α <-- z
              αλλιώς
                   A <-- x
              Τέλος_αν
         αλλιώς
              Αν x > 1 τότε
                   Α <-- ν
              αλλιώς
                   Α <-- 0
              Τέλος_αν
         Τέλος_αν
     αλλιώς
         Α <-- 1
     Τέλος_αν
     Εμφάνισε Α
     Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου