Δευτέρα, 7 Ιουνίου 2010

Άσκηση : Πρόγραμμα+Διαδικασία

Ι. Γράψτε πρόγραμμα το οποίο:
α) διαβάζει τα ονοματεπώνυμα και τις ηλικίες των
    26 ποδοσφαιριστών μιας ομάδας,
β) καλεί κατάλληλο υποπρόγραμμα προκειμένου να
    υπολογίσει:
    * το μέσο όρο ηλικίας της ομάδας,
    * το ονοματεπώνυμο του νεαρότερου ποδοσφαιριστή
       αυτής της ομάδας.
γ)  εμφανίζει τα παραπάνω αποτελέσματα με κατάλληλα
     διαμορφωμένα μηνύματα στην οθόνη.
ΙΙ. Να γράψετε το υποπρόγραμμα που καλείται στο
      ερώτημα Ι-β).

Λύση

      ΠΡΟΓΡΑΜΜΑ ΟΜΑΔΑ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: λ
             ΠΡΑΓΜΑΤΙΚΕΣ: Ηλικία[26], ΜΟ
             ΧΑΡΑΚΤΗΡΕΣ: Ονομ[26], Ον
      ΑΡΧΗ
             ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 26
                   ΔΙΑΒΑΣΕ Ονομ[λ]
                   ΔΙΑΒΑΣΕ Ηλικία[λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΚΑΛΕΣΕ ΥΠΟΛΟΓΙΣΜΟΙ(Ονομ, Ηλικία, ΜΟ, Ον)
             ΓΡΑΨΕ 'Μέσος όρος ηλικίας :', ΜΟ
             ΓΡΑΨΕ 'Νεαρότερος ποδοσφαιριστής :',  Ον
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

      ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛΟΓΙΣΜΟΙ(Ονομ, Ηλικία, ΜΟ, Ον)
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: λ
             ΠΡΑΓΜΑΤΙΚΕΣ: Ηλικία[26], ΜΟ, ΜΙΝ, Α
             ΧΑΡΑΚΤΗΡΕΣ: Ονομ[26], Ον
      ΑΡΧΗ
             Α <--Ηλικία[1]
             ΜΙΝ <-- Ηλικία[1]
             Ον <-- Ονομ[1]
             ΓΙΑ λ ΑΠΟ 2 ΜΕΧΡΙ 26
                   Α <-- Α+Ηλικία[λ]
                   ΑΝ Ηλικία[λ] < ΜΙΝ τότε
                        ΜΙΝ <-- Ηλικία[λ]
                        Ον <-- Ονομ[λ]
                   ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΜΟ <-- Α/26
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου