Τετάρτη, 2 Ιουνίου 2010

Άσκηση : Φρουρός+Απάντηση σε ερώτηση

Γράψτε πρόγραμμα το οποίο:
α) διαβάζει τα ονόματα των μαθητών μιας τάξης
    (η είσοδος δεδομένων ολοκληρώνεται μόλις
     δοθεί ως όνομα το κενό διάστημα ή όταν δοθεί
    η απάντηση 'Ο' στην υποβαλλόμενη προς το
    χρήστη ερώτηση 'Και άλλα δεδομένα;')
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των μαθητών της τάξης,
    * πόσοι μαθητές έχουν το όνομα 'ΝΙΚΟΣ'
    * το ποσοστό (%) των μαθητών που τα ονόματά
       τους προηγούνται αλφαβητικά του 'ΚΩΣΤΑΣ'

Λύση

     ΠΡΟΓΡΑΜΜΑ ΤΑΞΗ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Πλήθος, φ1, φ2
           ΧΑΡΑΚΤΗΡΕΣ: Όνομα, Επ
           ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΣΤΟ
     ΑΡΧΗ
           Πλήθος <-- 0
           φ1 <-- 0
           φ2 <-- 0
           ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΔΙΑΒΑΣΕ Όνομα
                ΑΝ Όνομα < > '  ' ΤΟΤΕ
                      Πλήθος <-- Πλήθος+1
                      ΑΝ Όνομα = 'ΝΙΚΟΣ' ΤΟΤΕ
                           φ1 <-- φ1+1
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ Όνομα < 'ΚΩΣΤΑΣ' ΤΟΤΕ
                           φ2 <-- φ2+1
                      ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
                ΓΡΑΨΕ 'Και άλλα δεδομένα;'
                ΔΙΑΒΑΣΕ Επ
           ΜΕΧΡΙΣ_ΟΤΟΥ (Επ = 'Ο') Ή (Όνομα = '  ')
           ΑΝ Πλήθος > 0 ΤΟΤΕ
                 ΠΟΣΟΣΤΟ <-- 100*φ2/Πλήθος
                 ΓΡΑΨΕ Πλήθος, φ1, ΠΟΣΟΣΤΟ
           ΑΛΛΙΩΣ
                 ΓΡΑΨΕ 'Δε δόθηκαν καθόλου δεδομένα'
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου