Τετάρτη, 1 Σεπτεμβρίου 2010

Δώστε την εκφώνηση της άσκησης

Δίνεται το παρακάτω πρόγραμμα
    ΠΡΟΓΡΑΜΜΑ ΑΣΚ
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Χ, σ, Υ
          ΑΚΕΡΑΙΕΣ: φ, πληθ
    ΑΡΧΗ
          φ <-- 0
          πληθ <-- 0
          σ <-- 0
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΔΙΑΒΑΣΕ Χ
                ΑΝ Χ > 0 ΤΟΤΕ
                     πληθ <-- πληθ+1
                     σ <-- σ+Χ
                     ΑΝ Χ < 50.3 ΤΟΤΕ
                          φ <-- φ+1
                     ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
          ΜΕΧΡΙΣ_ΟΤΟΥ Χ <= 0
          ΑΝ πληθ > 0 ΤΟΤΕ
                Υ <-- 100*φ/πληθ
                 ΓΡΑΨΕ σ, Υ
          ΑΛΛΙΩΣ
                 ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα'
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Ποιά είναι η εκφώνηση του προβλήμαυος που επιλύει;  

Απάντηση

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο διαβάζει κάποιους
πραγματικούς αριθμούς (η είσοδος δεδομένων ολοκληρώνεται
μόλις δοθεί μια μη θετική τιμή), υπολογίζει και εμφανίζει:
* το άθροισμα των τιμών εισόδου
* το ποσοστό (%) των τιμών εισόδου που είναι μικρότερες
   από το 50,3.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου