Τετάρτη, 29 Σεπτεμβρίου 2010

Βρείτε τα συντακτικά και τα λογικά λάθη

Το παρακάτω (αριθμημένο) σύνολο εντολών φιλοδοξεί να
υπολογίσει και να εμφανίσει το μέσο όρο ύψους των 20
μαθητών μιας τάξης
1     σ <-- 1
2    Διάβασε ΥΨΟΣ  
3    Για λ από 1 έως 20 
4          σ <-- σ+ΥΨΟΣ
5    Τέλοςεπανάληψης
6    Ε <-- σ/20
7    Εμφάνισε 'Ε'

Γράψτε τον αριθμό της σειράς (1-7), και το λάθος που υπάρχει
εκεί. Χαρακτηρίστε το κάθε λάθος και ξαναγράψτε το σύνολο
των εντολών από την αρχή έτσι ώστε να επιτυγχάνει το στόχο
της εκφώνησης.

Λύση

1. Λογικό λάθος, δεν πρέπει να εκχωρήσουμε στο σ το 1 αλλά
    το 0.
2. Λογικό λάθος,  η εντολή αυτή πρέπει να τοποθετηθεί μέσα στην
    Για..από..μέχρι, ακριβώς πριν την εντολή σ <-- σ+ΥΨΟΣ
3. Συντακτικό λάθος, αντί του έως πρέπει να χρησιμοποιηθεί η
    λέξη μέχρι
5. Συντακτικό λάθος, αντί του Τέλοςεπανάληψης πρέπει να
    χρησιμοποιηθεί η λέξη Τέλος_επανάληψης
6. Συντακτικό λάθος, το Ε είναι δεσμευμένη λέξη (είναι η
    εκθετική συνάρτηση) και πρέπει να χρησιμοποιηθεί ένα
    άλλο όνομα μεταβλητής για το αποτέλεσμα π.χ ΜΟ
7. Λογικό λάθος, η συγκεκριμένη εντολή θα τυπώσει το
    γράμμα Ε και όχι το αποτέλεσμα που έχουμ υπολογίσει.
    Το σωστό θα ήταν να εμφανίσουμε το περιεχόμενο της
    μεταβλητής που χρησιμοποιήσαμε στο 6.

Κατά συνέπεια το διορθωμένο σύνολο των εντολών έχει ως εξής:
      σ <-- 0
      Για λ από 1 μέχρι 20
           Διάβασε ΥΨΟΣ
           σ <-- σ+ΥΨΟΣ
      Τέλος_επανάληψης
      ΜΟ <-- σ/20
      Εμφάνισε ΜΟ

1 σχόλιο: