Δευτέρα, 6 Σεπτεμβρίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Όσο+Αν..τότε)

Ποιές είναι οι τελικές τιμές των μεταβλητών μετά την
εκτέλεση των παρακάτω εντολών;
     κ <-- 3
     λ <-- 18
     α <-- 0
     Όσο λ > 0 επαναλαβε 
          α <-- α+λ+2*κ
          κ <-- κ+2
          Αν λ > 5 τότε
               α <-- α-9
          Τέλος_αν
          λ <-- λ div 3
     Τέλος_επανάληψης

Λύση

     κ = 3
     λ = 18
     α = 0
     1η επανάληψη
          α = α+λ+2*κ = 0+18+2*3 = 18+6 = 24
          κ = κ+2 = 3+2 = 5
          Αφού λ > 5 = 18 > 5 = Αληθής έχουμε:
                α = α-9 = 24-9 = 15
          λ = λ div 3 = 18 div 3 = 6

     2η επανάληψη
          α = α+λ+2*κ = 24+6+2*5 = 30+10 = 40
          κ = κ+2 = 5+2 = 7
          Αφού λ > 5 = 6 > 5 =  Αληθής έχουμε:
                α = α-9 = 40-9 = 31
          λ = λ div 3 = 6 div 3 = 2
     3η επανάληψη     
          α = α+λ+2*κ = 40+2+2*7 = 42+14 =56
          κ = κ+2 = 7+2 =9
          Αφού λ > 5 = 2 > 5 =  Ψευδής το α δεν αλλάζει.
          λ = λ div 3 = 2 div 3 = 0
     Αφού λ > 0 = 0 > 0 = Ψευδής, η Όσο τερματίζεται.
     Οι τελικές τιμές των μεταβλητών είναι:
          λ = 0, κ = 9, α = 56

1 σχόλιο:

  1. Exeis ena lathos stin lysi, Stin deuteri epanalipsi otan ypologizei to a stin entoli a<--a+λ+2*k h timi tis a prepei na einai 15 kai oxi 24.

    ΑπάντησηΔιαγραφή