Παρασκευή, 10 Σεπτεμβρίου 2010

Άσκηση σε τρισδιάστατο πίνακα

Γράψτε αλγόριθμο που διαβάζει 150 ακέραιες τιμές και τις
καταχωρεί στον πίνακα Α[3, 5, 10]. Στη συνέχεια υπολογίζει
πόσες από αυτές είναι πολλαπλάσια του 17.

Λύση

      Αλγόριθμος ΤΡΙ
      Για λ από 1 μέχρι 3
          Για μ από 1 μέχρι 5
               Για ρ από 1 μέχρι 10
                     Διάβασε Α[λ, μ, ρ]
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης     
      Πολ <-- 0
      Για λ από 1 μέχρι 3
          Για μ από 1 μέχρι 5
               Για ρ από 1 μέχρι 10
                     Αν Α[λ, μ, ρ] mod 17 = 0 τότε
                          Πολ <-- Πολ+1
                     Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Αποτελέσματα // Πολ //
      Τέλος ΤΡΙ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου