Κυριακή, 12 Σεπτεμβρίου 2010

Άσκηση: βήμα-βήμα εκτέλεση (Για+Για)

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     α <-- 9
     β <-- 18
     Για λ από 80 μέχρι 101 με_βήμα 20
          Εμφάνισε α+β
          Για μ από 18 μέχρι 11 με_βήμα -6
                Εμφάνισε μ mod β
                β <-- β+5
          Τέλος_επανάληψης
          Εμφάνισε λ div α
          α <-- α+2
     Τέλος_επανάληψης
     Εμφάνισε α+β-λ+μ

Λύση

     α = 9
     β = 18
     λ = 80
          Αφού α+β = 9+18 = 27, η Εμφάνισε τυπώνει:    27
          μ = 18
              Αφού μ mod β = 18 mod 18 = 0, η Εμφάνισε τυπώνει:   0
              β = β+5 = 18+5 = 23
          μ = 12
             Αφού μ mod β = 12  mod 23 = 12, η Εμφάνισε τυπώνει:  12            
             β = β+5 = 23+5 = 28
          Η εσωτερική Για τερματίζεται με μ = 6
         Αφού λ div α = 80 div 9 = 8, η Εμφάνισε τυπώνει:  8
         α = α+2 = 9+2 = 11
     λ = 100
         Αφού α+β = 11+28= 39, η Εμφάνισε τυπώνει:    39
          μ = 18
              Αφού μ mod β = 18 mod 28 = 18, η Εμφάνισε τυπώνει:   18
              β = β+5 = 28+5 = 33
          μ = 12
             Αφού μ mod β = 12  mod  33 = 12, η Εμφάνισε τυπώνει:  12            
             β = β+5 = 33+5 = 38
         Η εσωτερική Για τερματίζεται με μ = 6
         Αφού λ div α = 100 div 11  = 9, η Εμφάνισε τυπώνει:  9
         α = α+2 = 11+2 = 13
    Η εξωτερική Για τερματίζεται με λ = 120
    Αφού α+β-λ+μ = 13+38-120+6 = -63, η Εμφάνισε τυπώνει:  -63

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου