Κυριακή, 19 Σεπτεμβρίου 2010

Δώστε την εκφώνηση της άσκησης

Δίνεται ο παρακάτω αλγόριθμος
    Αλγόριθμος Τι_κάνει
    χ <-- 0
    υ <-- 0
    Για κ από 1 μέχρι 120
           Διάβασε α
           Αν α mod 3 = 0 τότε
                χ <-- χ+1
           αλλιώς
                υ <-- υ+1
           Τέλος_αν
    Τέλος_επανάληψης
     ζ <-- 100*υ/120
     Αποτελέσματα // χ, ζ //
    Τέλος Τι_κάνει
Ποιά είναι η εκφώνηση του προβλήματος που επιλύει;

Λύση

Γράψτε αλγόριθμο που διαβάζει 120 ακέραιες τιμές και
υπολογίζει:
* το πλήθος των τιμών εισόδου που είναι πολλαπλάσια του 3,
* το ποσοστό (%) των τιμών εισόδου που δεν είναι πολλαπλάσια
   του 3

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου