Σάββατο, 18 Σεπτεμβρίου 2010

Άσκηση : έλεγχος τύπου δεδομένων και υπολογισμός

Γράψτε πρόγραμμα το οποίο διαβάζει μια αριθμητική τιμή,
υπολογίζει και εμφανίζει:
* το διπλάσιό της, αν η τιμή εισόδου είναι ακέραιος αριθμός
* το τριπλάσιό της, αν η τιμή εισόδου είναι πραγματικός
   αριθμός.

Λύση

     ΠΡΟΓΡΑΜΜΑ Υπ
     ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Χ, Υ
     ΑΡΧΗ
          ΔΙΑΒΑΣΕ Χ
          ΑΝ Α_Μ(Χ) = Χ ΤΟΤΕ
                Υ <-- 2*Χ
          ΑΛΛΙΩΣ
                 Υ <-- 3*Χ
          ΤΕΛΟΣ_ΑΝ
          ΓΡΑΨΕ Υ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου