Δευτέρα, 13 Σεπτεμβρίου 2010

Άσκηση : Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν έτσι ώστε το
παρακάτω πρόγραμμα να υπολογίζει και να
εμφανίζει το πλήθος των περιττών αριθμών σε
μια ακολουθία εισόδου που τερματίζεται μόλις δοθεί
η τιμή 1000.

     ΠΡΟΓΡΑΜΜΑ ΦΡ
     ΜΕΤΑΒΛΗΤΕΣ
           _______ : Χ, ΠΛΗΘ
     ΑΡΧΗ
          ΠΛΗΘ <-- ____
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ______ Χ
                ΑΝ Χ ____ 1000 ΤΟΤΕ
                   ΑΝ Χ _____ 2 = ____ ΤΟΤΕ
                       ΠΛΗΘ <-- ___ + ___
                   ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ

          ΜΕΧΡΙΣ_ΟΤΟΥ  ____ = ____
          _____ ΠΛΗΘ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Απάντηση

     ΠΡΟΓΡΑΜΜΑ ΦΡ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Χ, ΠΛΗΘ
     ΑΡΧΗ
          ΠΛΗΘ <-- 0
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΔΙΑΒΑΣΕ Χ
                ΑΝ Χ < > 1000 ΤΟΤΕ
                   ΑΝ Χ MOD 2 = 1 ΤΟΤΕ
                       ΠΛΗΘ <-- ΠΛΗΘ+1
                   ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
          ΜΕΧΡΙΣ_ΟΤΟΥ  Χ = 1000
          ΓΡΑΨΕ ΠΛΗΘ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου