Παρασκευή, 17 Σεπτεμβρίου 2010

Κάντε τις σωστές αντιστοιχήσεις

Δίνονται τα παρακάτω σύνολα εντολών
    1. 
       χ <-- 7
       Όσο χ > 0 επανάλαβε
            χ <-- χ-2
       Τέλος_επανάληψης

    2.
        χ <-- -4
        Για κ από 10 μέχρι 9 με_βήμα -1
              χ <-- χ+1
        Τέλος_επανάληψης

    3. 
        χ <-- -1
        Για λ από 2010 μέχρι 2010
             χ <-- χ+1
        Τέλος_επανάληψης

     4.
         χ <-- -4
         Αρχή_επανάληψης
              χ <-- χ+2
         Μέχρις_ότου χ <= 0

      5.
          χ <-- -3
          Αρχή_επανάληψης
               Αν χ > 0 τότε
                   χ <-- -χ
               Τέλος_αν
               χ <-- χ-1
          Μέχρις_ότου  χ < -3
    
    και οι τιμές

         α. -4
         β. -3
         γ. -2
         δ. -1
         ε. 0

Γράψτε στο τετράδιό σας τον αριθμό του τμήματος εντολών
(1-5) και δίπλα το γράμμα (α-ε) που αντιστοιχεί στην τελική
τιμή του χ.

Απάντηση

       1. δ
       2. γ
       3. ε
       4. γ
       5. α

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου