Πέμπτη, 9 Σεπτεμβρίου 2010

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν έτσι ώστε το παρακάτω
σύνολο εντολών να υπολογίζει το άθροισμα των τετραγώνων
όλων των θετικών άρτιων αριθμών που είναι πολλαπλάσια του 8
και μικρότεροι από το 300
      Α <-- ____
      Για λ από _____ μέχρι ____ με_βήμα ____
             Αν (λ ____ 2 = ____ ) ΚΑΙ (λ ____ = 0) τότε
                    Α <-- Α+___
             Τέλος_αν
      Τέλος_επανάληψης
      Αποτελέσματα // Α //

Λύση

      Α <-- 0
      Για λ από 2 μέχρι 298 με_βήμα 2
             Αν mod 2 = 0) ΚΑΙ mod 8 = 0) τότε
                    Α <-- Α+λ^2
             Τέλος_αν
      Τέλος_επανάληψης
      Αποτελέσματα // Α //

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου