Κυριακή, 12 Σεπτεμβρίου 2010

Άσκηση : μικρότερο και μεγαλύτερο ψηφίο θετικού τετραψήφιου

Γράψτε αλγόριθμο που:
α) διαβάζει ένα θετικό τετραψήφιο αριθμό (διασφαλίζοντας
    την εγκυρότητα της εισερχόμενης τιμής),
β) υπολογίζει και εμφανίζει  το μεγαλύτερο ψηφίο  του παραπάνω
    αριθμού.

Λύση

     Αλγόριθμος ΜΑΧ_ΨΗΦ
     Αρχή_επανάληψης
          Διάβασε Ν
     Μέχρις_ότου (Ν >= 1000) ΚΑΙ (Ν <= 9999)
     ΧΙΛ <-- N div 1000
     ΕΚΑΤ <-- (Ν mod 1000) div 100
     ΔΕΚ <-- ( (Ν mod 1000) mod 100) div 10
     ΜΟΝ <-- ( (Ν mod 1000) mod 100) mod 10
     MAX <-- ΧΙΛ
     Αν  ΕΚΑΤ >ΜΑΧ τότε
          ΜΑΧ <-- ΕΚΑΤ
     Τέλος_αν
     Αν ΔΕΚ >ΜΑΧ τότε
          ΜΑΧ <-- ΔΕΚ
     Τέλος_αν
     Αν  ΜΟΝ >ΜΑΧ τότε
          ΜΑΧ <-- ΜΟΝ
     Τέλος_αν
     Εμφάνισε  ΜΑΧ

     Τέλος ΜΑΧ_ΨΗΦ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου