Σάββατο, 18 Σεπτεμβρίου 2010

Άσκηση : Ποιό είναι το περιεχόμενο του πίνακα

Ποιό είναι το περιεχόμενο του πίνακα Α[3, 6] μετά την
εκτέλεση των παρακάτω εντολών;
      Για μ από 1 μέχρι 3
           Για λ από 1 μέχρι 6
                Αν (μ = 1) Ή (λ = 1) τότε
                     Α[μ, λ] <-- 11
                αλλιώς_αν μ = 3 τότε
                     Α[μ, λ] <-- 0
                αλλιώς
                     Α[μ, λ] <-- 99
                Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης
   
Λύση

      Μετά την εκτέλεση των παραπάνω εντολών
      * όλα τα στοιχεία της 1ης γραμμής  και της 1ης στήλης
         παίρνουν την τιμή 11,
      * όλα τα στοιχεία της 3ης γραμμής παίρνουν την τιμή 0
         (εκτός από το Α[3, 1]),
      * όλα τα υπόλοιπα στοιχεία του πίνακα παίρνουν την
         τιμή 99
      Κατά συνέπεια το περιεχόμενο του πίνακα είναι το
      ακόλουθο:

             11     11     11     11     11     11
             11     99     99     99     99     99
             11      0       0       0       0       0

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου