Παρασκευή, 3 Σεπτεμβρίου 2010

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους δύο
ακέραιες τιμές Α, Β και υπολογίζει το πλήθος των ακέραιων
λύσεων της εξίσωσης
       ΑΧ+ΒΥ = 0
στο διάστημα [-1000, 1000]

Λύση

      ΣΥΝΑΡΤΗΣΗ Πλήθος_Λύσεων(Α, Β) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α, Β, Χ, Υ, Πληθ
      ΑΡΧΗ
            Πληθ <-- 0
            ΓΙΑ Χ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                 ΓΙΑ Υ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                       ΑΝ Α*Χ+Β*Υ = 0 ΤΟΤΕ
                             Πληθ <-- Πληθ+1
                       ΤΕΛΟΣ_ΑΝ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Πλήθος_Λύσεων <-- Πληθ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου