Κυριακή, 19 Σεπτεμβρίου 2010

Μενού λειτουργιών

Γράψτε πρόγραμμα το οποίο παρέχει το ακόλουθο μενού
λειτουργιών
     1.  Υπολογισμός α+β*γ
     2.  Υπολογισμός α-β
     3.  Υπολογισμός α+β-γ*δ
     4.  Έξοδος
Όταν η επιλογή του χρήστη είναι 1-3, διαβάζονται οι
απαιτούμενες (ακέραιες) τιμές εισόδου, γίνεται ο αντί-
στοιχος υπολογισμός και εμφανίζεται το αποτέλεσμα
στην οθόνη με κατάλληλα διαμορφωμένο μήνυμα.Η
λειτουργία του προγράμματος ολοκληρώνεται μόνο όταν
δοθεί ως επιλογή του χρήστη η τιμή 4.
Παρατήρηση : Το πρόγραμμα πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΜΕΝΟΥ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: ΕΠ, α, β, γ, δ, ΑΠ
     ΑΡΧΗ
           ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΓΡΑΨΕ '1.  Υπολογισμός α+β*γ'
                ΓΡΑΨΕ '2.  Υπολογισμός α-β'
                ΓΡΑΨΕ '3.  Υπολογισμός α+β-γ*δ'
                ΓΡΑΨΕ '4.  Έξοδος'
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                     ΓΡΑΨΕ 'Δώσε επιλογή:'
                     ΔΙΑΒΑΣΕ ΕΠ
                ΜΕΧΡΙΣ_ΟΤΟΥ (ΕΠ >= 1) ΚΑΙ (ΕΠ <= 4)
                ΑΝ ΕΠ = 1 ΤΟΤΕ
                           ΔΙΑΒΑΣΕ α, β, γ
                           ΑΠ <-- α+β*γ
                           ΓΡΑΨΕ 'α+β*γ = ', ΑΠ
               ΑΛΛΙΩΣ_ΑΝ ΕΠ = 2 ΤΟΤΕ
                           ΔΙΑΒΑΣΕ α, β
                           ΑΠ <-- α-β
                           ΓΡΑΨΕ 'α-β = ', ΑΠ                      
               ΑΛΛΙΩΣ_ΑΝ ΕΠ = 3 ΤΟΤΕ         
                           ΔΙΑΒΑΣΕ α, β, γ, δ
                           ΑΠ <-- α+β-γ*δ
                           ΓΡΑΨΕ 'α+β-γ*δ = ', ΑΠ                      
               ΑΛΛΙΩΣ
                           ΓΡΑΨΕ 'Τερματισμός λειτουργιών'
               ΤΕΛΟΣ_ΑΝ
           ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠ = 4
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου