Κυριακή, 5 Σεπτεμβρίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Για+Αν..τότε..αλλιώς_αν)

Ποιές είναι οι τελικές τιμές των μεταβλητών μετά την
εκτέλεση των παρακάτω εντολών;
    α <-- -2
    β <-- 13
    γ <-- 91
    Για λ από 10 μέχρι 23 με_βήμα 6
          Αν λ mod 5 = 0 τότε
              α <-- α+3
              β <-- β-1
              γ <-- γ-2
          αλλιώς_αν λ mod 4 = 0 τότε
              α <-- α+7
              β <-- β+5
              γ <-- γ-9
          αλλιώς
              α <-- α*2
              β <-- β*3
              γ <-- γ+1
          Τέλος_αν
    Τέλος_επανάληψης
    α <-- α+λ
    β <-- β+α
    γ <-- γ-β

Λύση

    α = -2
    β = 13
    γ = 91
    λ = 10
         Αφού λ mod 5 = 10 mod 5 = 0 έχουμε:
              α = α+3 = -2+3 = 1
              β = β-1 = 13-1 = 12
              γ = γ-2 = 91-2 = 89
    λ = 16
         Αφού λ mod 5 = 16 mod 5 = 1 και
         λ mod 4 = 16 mod 4 = 0 έχουμε:
              α = α+7 = 1+7 = 8
              β = β+5 = 12+5 = 17
              γ = γ-9 = 89-9 = 80
    λ = 22
         Αφού λ mod 5 =  22 mod 5 = 2 και 
         λ mod 4 = 22 mod 4 = 2 έχουμε:
              α = α*2 = 8*2 = 16
              β = β*3 = 17*3 = 51
              γ = γ+1 = 80+1 = 81     
    Η Για τερματίζεται με λ = 28. 
    α = α+λ = 16+28 = 44
    β = β+α = 51+44 = 95
    γ = γ-β = 81-95 = -14
Κατά συνέπεια οι τελικές τιμές των μεταβλητών είναι:
    α = 44, β = 95, γ = -14, λ = 28

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου