Σάββατο, 25 Σεπτεμβρίου 2010

Είναι ισοδύναμα;

Είναι ισοδύναμα τα παρακάτω τμήματα εντολών;

    Τμήμα Α

         α <-- 0
         Για λ από μέχρι 13 με_βήμα 2
              α <-- α+1
         Τέλος_επανάληψης

    Τμήμα Β

         α <-- 14
         Για λ από 22 μέχρι 16 με_βήμα -1
               α <-- α-1
         Τέλος_επανάληψης

Λύση

       Τμήμα Α
               α = 0
               Η Για..από..μέχρι εκτελείται 7 φορές και τερματίζεται
               με λ = 15
               Κατά συνέπεια προστίθεται στο α η μονάδα 7 φορές και
               η τελική τιμή του είναι:
                      α = 0+7*1 = 7

       Τμήμα Β
               α = 14
               Η Για..από..μέχρι εκτελείται 7 φορές και τερματίζεται
               με λ = 15
               Κατά συνέπεια αφαιρείται από το α η μονάδα 7 φορές και
               η τελική τιμή του είναι:
                      α = 14-7*1 = 7

        Αφού οι τελικές τιμές των μεταβλητών α, λ είναι οι ίδιες και στα
        δύο τμήματα εντολών, τα τμήματα αυτά είναι ισοδύναμα
        μεταξύ τους.


    

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου