Τετάρτη, 8 Σεπτεμβρίου 2010

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν στο παρακάτω σύνολο
εντολών έτσι ώστε αυτό να υπολογίζει το ποσοστό (%) των
περιττών αριθμών (μέχρι και το 189) που δεν είναι
πολλαπλάσια του 3.
       χ <-- 0
       Για λ από ____ μέχρι ____  με_βήμα ____
             Αν λ ___ 3 = ____ τότε
                    χ <-- χ+1
             Τέλος_αν
       Τέλος_επανάληψης
       ΠΟΣ <-- 100*(95-χ)/___
       Εμφάνισε 'Ποσοστό =', ΠΟΣ, '%'

Απάντηση

       χ <-- 0
       Για λ από 1 μέχρι 189  με_βήμα 2
             Αν λ mod 3 = 0 τότε
                    χ <-- χ+1
             Τέλος_αν
       Τέλος_επανάληψης
       ΠΟΣ <-- 100*(95-χ)/95
       Εμφάνισε 'Ποσοστό =', ΠΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου