Τετάρτη, 22 Σεπτεμβρίου 2010

Πολλαπλές Μετατροπές

Δίνεται το παρακάτω σύνολο εντολών
     Για λ από 21 μέχρι 3 με_βήμα -4
            Αν λ > 10 τότε
                   κ <-- 2
                   Όσο κ < λ επανάλαβε
                        Εμφάνισε κ+λ
                        κ <-- κ+1
                   Τέλος_επανάληψης
            αλλιώς
                   κ <-- 32
                   Αρχή_επανάληψης
                        Εμφάνισε κ-λ
                        κ <-- κ-2
                   Μέχρις_ότου κ > λ
            Τέλος_αν
     Τέλος_επανάληψης
Ξαναγράψτε το αντικαθιστώντας:
α) Τη Για..από..μέχρι με Όσο..επανάλαβε
β) Την Όσο..επανάλαβε με Μέχρις_ότου
γ) Την  Μέχρις_ότου με Όσο..επανάλαβε
δ) Την Αν..τότε..αλλιώς με εντολές Αν..τότε

Λύση


       λ <-- 21
       Όσο λ >= 3 επανάλαβε

            Αν λ > 10 τότε
                   κ <-- 2
                   Αρχή_επανάληψης
                        Εμφάνισε κ+λ
                        κ <-- κ+1
                   Μέχρις_ότου κ >= λ
            Τέλος_αν
            Αν λ <= 10 τότε
                   κ <-- 32
                   Όσο κ <= λ επανάλαβε
                        Εμφάνισε κ-λ
                        κ <-- κ-2

                   Τέλος_επανάληψης
            Τέλος_αν
            λ <-- λ-4
     Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου