Κυριακή, 19 Σεπτεμβρίου 2010

Άσκηση : Πρόγραμμα+Διαδικασία

1. Γράψτε διαδικασία που δέχεται ως παραμέτρους τα μήκη
    των πλευρών ενός ορθογωνίου παραλληλογράμμου και
    υπολογίζει:
    α) το εμβαδόν του,
    β) την περίμετρό του.
2. Γράψτε πρόγραμμα το οποίο:
    α) διαβάζει τα μήκη των πλευρών μιας ομάδας ορθογωνίων
         παραλληλογράμμων (η είσοδος ολοκληρώνεται μόλις
         τουλάχιστον μια από τις τιμές εισόδου είναι μη θετικός
        αριθμός),
    β) καλώντας τη διαδικασία που γράψατε στο ερώτημα 1,
        υπολογίζει το εμβαδόν και την περίμετρο του καθενός
       από τα παραπάνω ορθογώνια παραλληλόγραμμα και στη
       συνέχεια εμφανίζει τα αποτελέσματα αυτά με κατάλληλα
       διαμορφωμένα μηνύματα στην οθόνη.

Λύση

       ΠΡΟΓΡΑΜΜΑ ΟΡΘΟΓ
       ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: α, β, Εμβ, Περ
       ΑΡΧΗ
             ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ α, β
                    ΑΝ (α > 0) ΚΑΙ (β > 0) ΤΟΤΕ
                          ΚΑΛΕΣΕ ΕΜΒ_ΠΕΡ(α, β, Εμβ, Περ)
                          ΓΡΑΨΕ 'Εμβαδόν = ', Εμβ
                          ΓΡΑΨΕ 'Περίμετρος = ', Περ
                    ΤΕΛΟΣ_ΑΝ
             ΜΕΧΡΙΣ_ΟΤΟΥ (α <= 0) Ή (β <= 0)
       ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

       ΔΙΑΔΙΚΑΣΙΑ ΕΜΒ_ΠΕΡ(α, β, Εμβ, Περ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: α, β, Εμβ, Περ
       ΑΡΧΗ
             Εμβ <-- α*β
             Περ <-- 2*α+2*β
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου