Πέμπτη, 23 Σεπτεμβρίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Μέχρις_ότου+Αν..τότε)

Τι θα εμφανίσει στη μονάδα εξόδου το παρακάτω σύνολο
εντολών;
   μ <-- 12
   ν <-- 17
   Αρχή_επανάληψης
        Αν μ < 20 τότε
             μ <-- 2*μ
        Τέλος_αν
        Αν ν <= 25 τότε
             ν <-- ν+8
        Τέλος_αν
        Εμφάνισε  μ, ν
        μ <-- μ+1
        ν <-- ν+1
   Μέχρις_ότου  μ+ν > 62
   Εμφάνισε (μ-ν)^2

Λύση

    μ = 12
    ν = 17
    1η επανάληψη
         Αφού μ < 20 = 12 < 20 = Αληθής έχουμε:
              μ = 2*μ = 2*12 = 24
         Αφού ν <= 25 = 17 <= 25 = Αληθής έχουμε:
              ν = ν+8 = 17+8 = 25
         Η Εμφάνισε τυπώνει:             24       25
         μ = μ+1 = 24+1 = 25
         ν = ν+1 = 25+1 = 26
    2η επανάληψη
         Αφού μ < 20 = 25 < 20 = Ψευδής δεν εκτελείται η
         εντολή εκχώρησης της πρώτης Αν..τότε.
         Αφού ν <= 25 = 26 <= 25 = Αληθής έχουμε:
              ν = ν+8 = 26+8 = 34
         Η Εμφάνισε τυπώνει:             25       34
         μ = μ+1 = 25+1 = 26
         ν = ν+1 = 34+1 = 35
    3η επανάληψη
         Αφού μ < 20 = 26 < 20 = Ψευδής δεν εκτελείται η
         εντολή εκχώρησης της πρώτης Αν..τότε.
         Αφού ν <= 25 = 35 <= 25 = Ψευδής δεν εκτελείται η 
         εντολή εκχώρησης της δεύτερης Αν..τότε.
         Η Εμφάνισε τυπώνει:             26       35
         μ = μ+1 = 26+1 = 27
         ν = ν+1 = 35+1 = 36
    Αφού μ+ν > 62 = 27+36 > 62 = 63 > 62 = Αληθής,
    η Μέχρις_ότου τερματίζεται.
    Επειδή (μ-ν)^2 = (27-36)^2 = (-9)^2 = 81,
    η Εμφάνισε τυπώνει:         81

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου