Πέμπτη, 2 Σεπτεμβρίου 2010

Άσκηση : Ποιά είναι η τελική τιμή της μεταβλητής;

Ποιά είναι η τελική τιμή της μεταβλητής κ μετά την εκτέλεση
των παρακάτω εντολών;
     κ <-- 100
     Για λ από 4 μέχρι 24 με_βήμα 7
          κ <-- κ-3
          μ <-- λ mod 30
          Όσο μ >= 25 επανάλαβε
               κ <-- κ+1
               μ <-- μ-5
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση
  
     Όποια τιμή και αν πάρει το λ, το λ mod 30 = λ (αφού
     λ < 30). Αυτό σημαίνει ότι η συνθήκη μ >= 25 θα είναι
     πάντοτε Ψευδής και η περιεχόμενη ομάδα εντολών της
     Όσο..επανάλαβε δε θα εκτελεστεί καμία φορά.
     Κατά συνέπεια μόνο η εντολή κ <-- κ-3 μεταβάλλει
     την τιμή της κ και αφού η Για..από..μέχρι εκτελείται
     3 φορές, η τελική τιμή του κ είναι : 100-3*3 = 91

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου