Παρασκευή, 3 Σεπτεμβρίου 2010

Άσκηση: Συγγραφή διαδικασίας που καλεί συναρτήσεις

Ι. Γράψτε συνάρτηση Φ που δέχεται ως παράμετρο τον
   πραγματικό πίνακα Β[187, 32] και υπολογίζει το μέσο
   όρο της 43ης γραμμής.
ΙΙ. Γράψτε συνάρτηση Ρ που δέχεται ως παράμετρο τον 
     πραγματικό πίνακα Β[187, 32] και υπολογίζει το
     γινόμενο των στοιχείων της 2ης στήλης.
ΙΙΙ. Γράψτε διαδικασία Δ που δέχεται ως παράμετρο τον      
      πραγματικό πίνακα Β[187, 32] και :
      * καλεί με κατάλληλο τρόπο την Φ και καταχωρεί
         το αποτέλεσμά της στην πραγματική μεταβλητή Χ,
      * καλεί με κατάλληλο τρόπο την Ρ και καταχωρεί
         το αποτέλεσμά της στην πραγματική μεταβλητή Υ,
      * γεμίζει όλο τον πίνακα με το αποτέλεσμα της
         παράστασης 5*Χ+3*Υ

Λύση

       ΣΥΝΑΡΤΗΣΗ Φ(Β) : ΠΡΑΓΜΑΤΙΚΗ
       ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: Β[187, 32], Α
             ΑΚΕΡΑΙΕΣ: κ
       ΑΡΧΗ
             Α <-- 0
             ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 32
                  Α <-- Α+Β[43, κ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             Φ <-- Α/32
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

       ΣΥΝΑΡΤΗΣΗ Ρ(Β) : ΠΡΑΓΜΑΤΙΚΗ
       ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: Β[187, 32], Γ
             ΑΚΕΡΑΙΕΣ: κ
       ΑΡΧΗ
             Γ <-- 1
             ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 187
                  Γ <-- Γ*Β[κ, 2]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             Ρ <-- Γ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

       ΔΙΑΔΙΚΑΣΙΑ Δ(Β) 
       ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: Β[187, 32], Χ, Υ, Αποτ
             ΑΚΕΡΑΙΕΣ: κ, λ
       ΑΡΧΗ
             Χ <-- Φ(Β)
             Υ <-- Ρ(Β)
             Αποτ <-- 5*Χ+3*Υ
             ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 187
                  ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 32
                       Β[κ, λ] <-- Αποτ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου