Κυριακή, 26 Σεπτεμβρίου 2010

Άσκηση : Αν..τότε..αλλιώς+Αν..τότε..αλλιώς_αν

Γράψτε πρόγραμμα το οποίο διαβάζει μια ακέραια τιμή Χ
και υπολογίζει την τιμή της συνάρτησης Φ με τύπο:
                        Χ/(Χ+20), αν Χ < 0
       Φ(Χ)  =     Χ/(Χ-19), αν 0 <= Χ <= 21
                        Χ+1, αν Χ > 21

Λύση

     ΠΡΟΓΡΑΜΜΑ Φ_Χ
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Χ
          ΠΡΑΓΜΑΤΙΚΕΣ: Υ
     ΑΡΧΗ
          ΔΙΑΒΑΣΕ Χ
          ΑΝ (Χ = -20) Ή (Χ = 19) ΤΟΤΕ
                ΓΡΑΨΕ 'Η συνάρτηση δεν ορίζεται!'
          ΑΛΛΙΩΣ
                ΑΝ Χ < 0 ΤΟΤΕ
                      Υ <-- Χ/(Χ+20)
                ΑΛΛΙΩΣ_ΑΝ Χ <= 21 ΤΟΤΕ
                      Υ <-- Χ/(Χ-19)
                ΑΛΛΙΩΣ
                      Υ <-- Χ+1
                ΤΕΛΟΣ_ΑΝ
                ΓΡΑΨΕ  'Φ(Χ) = ', Υ 
          ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου