Δευτέρα, 27 Σεπτεμβρίου 2010

Άσκηση : μετατροπή από Αν..τότε..αλλιώς_αν σε άλλες δομές επιλογές.

Δίνεται το ακόλουθο τμήμα εντολών
     Αν (μ = '@') Ή (μ = '!') τότε
           α <-- 100
     αλλιώς_αν μ = '*' τότε
           α <-- 90
     αλλιώς_αν (μ = '+') Ή (μ = '&') Ή (μ = '$') τότε
           α <-- 80
     αλλιώς
           α <-- 70
     Τέλος_αν
Ξαναγράψτε το ισοδύναμα αντικαθιστώντας την εντολή
Αν..τότε..αλλιώς_αν με
α) με εμφωλευμένες Αν..τότε..αλλιώς
β) με εντολές Αν..τότε
γ) με μια Επίλεξε

Λύση

α)
     Αν (μ = '@') Ή (μ = '!') τότε
           α <-- 100
     αλλιώς
          Αν μ = '*' τότε
                α <-- 90
          αλλιώς
               Αν (μ = '+') Ή (μ = '&') Ή (μ = '$') τότε
                    α <-- 80
               αλλιώς
                    α <-- 70
               Τέλος_αν
           Τέλος_αν
     Τέλος_αν

β)
     Αν (μ = '@') Ή (μ = '!') τότε
           α <-- 100
     Τέλος_αν
     Αν μ = '*' τότε
           α <-- 90
     Τέλος_αν
     Αν (μ = '+') Ή (μ = '&') Ή (μ = '$') τότε
           α <-- 80
     Τέλος_αν
     Αν (μ < > '@') ΚΑΙ (μ < > '!') ΚΑΙ (μ < > '*') ΚΑΙ
           (μ < > '+') ΚΑΙ (μ < > '&') ΚΑΙ (μ < > '$') τότε
           α <-- 70
     Τέλος_αν

γ)
     Επίλεξε μ
         Περίπτωση '@', '!'
              α <-- 100
         Περίπτωση '*'
              α <--90
         Περίπτωση '+', '&', '$'
              α <--80
         Περίπτωση αλλιώς
              α <-- 70
      Τέλος_επιλογών
 

 

 





 



 

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου