Πέμπτη, 2 Σεπτεμβρίου 2010

Διορθώστε τα λάθη

Δίνεται το παρακάτω πρόγραμμα που υλοποιεί τον
πολλαπλασιασμό αλά ρωσικά
    ΠΡΟΓΡΑΜΜΑ ΠΟΛ
    ΜΕΤΑΒΛΗΤΕΣ
         ΑΚΕΡΑΙΕΣ: Μ1, Μ2, Ρ
    ΑΡΧΗ
         ΔΙΑΒΑΣΕ Μ1, Μ2
         Ρ <-- 0
         ΟΣΟ Μ1 > 0 ΕΠΑΝΑΛΑΒΕ
              ΑΝ Μ2 MOD 2 = 1 TOTE
                  Ρ <-- Ρ+Μ2
                  Μ1 <-- Μ1*2
                  Μ2 <-- Μ2 DIV 2
              ΤΕΛΟΣ_ΑΝ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΓΡΑΨΕ Ρ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Κάντε τις απαραίτητες διορθώσεις έτσι ώστε να διασφαλίσετε
την ορθή λειτουργία του προγράμματος.

Λύση

    ΠΡΟΓΡΑΜΜΑ ΠΟΛ
    ΜΕΤΑΒΛΗΤΕΣ
         ΑΚΕΡΑΙΕΣ: Μ1, Μ2, Ρ
    ΑΡΧΗ
         ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΔΙΑΒΑΣΕ Μ1, Μ2
         ΜΕΧΡΙΣ_ΟΤΟΥ (Μ1 > 0) ΚΑΙ (Μ2 > 0)
         Ρ <-- 0
         ΟΣΟ Μ2 > 0 ΕΠΑΝΑΛΑΒΕ
              ΑΝ Μ2 MOD 2 = 1 TOTE
                  Ρ <-- Ρ+Μ1
              ΤΕΛΟΣ_ΑΝ
              Μ1 <-- Μ1*2
              Μ2 <-- Μ2 DIV 2
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΓΡΑΨΕ Ρ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου