Τετάρτη, 15 Σεπτεμβρίου 2010

Άσκηση : Φρουρός

Γράψτε αλγόριθμο που διαβάζει τις ταχύτητες (σε GHz) κάποιων
επεξεργαστών (η είσοδος τερματίζεται μόλις δοθεί μια
μη θετική τιμή), υπολογίζει και εμφανίζει:
α) το πλήθος των επεξεργαστών,
β) πόσοι επεξεργαστές είχαν ταχύτητα μεγαλύτερη από
    2.8 GHz

Λύση

     Αλγόριθμος ΚΜΕ
     Πληθ <-- 0
     Φ28 <-- 0
     Αρχή_επανάληψης
          Διάβασε Ταχ
          Αν Ταχ > 0 τότε
               Πληθ <-- Πληθ+1
               Αν Ταχ > 2.8 τότε
                   Φ28 <-- Φ28+1
               Τέλος_αν
          Τέλος_αν
     Μέχρις_ότου Ταχ <= 0
     Εμφάνισε Πληθ, Φ28
     Τέλος ΚΜΕ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου