Τρίτη, 28 Σεπτεμβρίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Όσο+Αν..τότε..αλλιώς_αν)

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     λ <-- 10
     Α <-- 13
     Όσο λ > 0 επανάλαβε
          Αν λ > 8 τότε
               Α <-- Α+2*λ
          αλλιώς_αν λ > 5 τότε
               Α <-- Α-λ
          αλλιώς
               Α <-- Α+1
          Τέλος_αν
          Εμφάνισε 'Α < λ', λ mod 4 = 0, A >= 28
          λ <-- λ-3
     Τέλος_επανάληψης
     Εμφάνισε Α, λ

Λύση

      λ = 10
      Α = 13
      1η επανάληψη
            Αφού λ > 8 = 10 > 8 = Αληθής έχουμε:
                   Α = Α+2*λ = 13+2*10 = 13+20 = 33
            Επειδή (λ mod 4 = 0) = (10 mod 4 = 0) =(2 = 0) =
            Ψευδής και A >= 28 = 33 >= 28 = Αληθής
             η Εμφάνισε τυπώνει:
                   Α < λ    Ψευδής    Αληθής
             λ = λ-3 = 10-3 = 7
      2η επανάληψη
            Αφού λ > 8 = 7 > 8 = Ψευδής και λ > 5 = 7 > 5 = Αληθής
            έχουμε:
                   Α = Α-λ = 33-7 = 26
            Επειδή (λ mod 4 = 0) = (7 mod 4 = 0) =(3 = 0) =
            Ψευδής και A >= 28 = 26 >= 28 = Ψευδής
             η Εμφάνισε τυπώνει:
                   Α < λ    Ψευδής    Ψευδής
             λ = λ-3 = 7-3 =4
      3η επανάληψη
            Αφού λ > 8 = 4 > 8 = Ψευδής και λ > 5 = 4 > 5 = Ψευδής
            έχουμε:
                   Α = Α+1 = 26+1 = 27
            Επειδή (λ mod 4 = 0) = (4 mod 4 = 0) =(0 = 0) =
            Αληθης και A >= 28 = 27 >= 28 = Ψευδής
             η Εμφάνισε τυπώνει:
                   Α < λ    Αληθής    Ψευδής
             λ = λ-3 = 4-3 =1
       4η επανάληψη
            Αφού λ > 8 = 1 > 8 = Ψευδής και λ > 5 = 1 > 5 = Ψευδής
            έχουμε:
                   Α = Α+1 = 27+1 = 28
            Επειδή (λ mod 4 = 0) = (1 mod 4 = 0) =(1 = 0) =
            Ψευδής και A >= 28 = 28 >= 28 = Αληθής
             η Εμφάνισε τυπώνει:
                   Α < λ    Ψευδής   Αληθής
             λ = λ-3 = 1-3 = -2
        Αφού λ > 0 = -2 > 0 = Ψευδής, η Όσο τερματίζεται.
        Η Εμφάνισε τυπώνει:
              28       -2

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου