Κυριακή, 19 Σεπτεμβρίου 2010

Βρείτε τα συντακτικά και λογικά λάθη

Τα παρακάτω σύνολα εντολών φιλοδοξούν να υπολογίσουν
το μέσο όρο ύψους 20 ατόμων, ωστόσο έχουν κάποια λάθη.
Ποιά από αυτά είναι συντακτικά και ποιά λογικά;

 1.
     Για κ από 1 μέχρι 20
           Διάβασε Υ
           σ <-- σ+Υ
     Τέλος_επανάληψης
     Εμφάνισε σ/20

2.
     σ <-- 0
     Για κ από 1 μέχρι 20
           Διάβασε σ
           σ <-- σ+Υ
     Τέλος_επανάληψης
     Εμφάνισε σ/20
 
3.
     σ <-- 0
     Για κ από 1 μέχρι 20
           Διάβασε Υ
           σ = σ+Υ
     Τέλος_επανάληψης
     Εμφάνισε σ/20

4.
     σ <-- 0
     Για κ από 1 μέχρι 20 κάνε
           Διάβασε Υ
           σ <-- σ+Υ
     Τέλος_επανάληψης
     Εμφάνισε σ/20

5.
     σ <-- 0
     Για κ από 1 μέχρι 20
           Διάβασε Υ
           σ <-- σ+Υ
     Τέλος_επανάληψης
     Εμφάνισε σ

Απάντηση

    1. Λογικό λάθος,γιατί δε μηδενίσαμε έξω από τη Για το σ.
    2. Λογικό λάθος,γιατί αντί να διαβάζουμε την τιμή του Υ,
        διαβάζουμε το σ.
    3. Συντακτικό λάθος, γιατί η εντολή σ = σ+Υ έπρεπε να ήταν
        σ <-- σ+Υ
    4. Συντακτικό λάθος, γιατί η λέξη κάνε είναι περιττή.
    5. Λογικό λάθος, γιατί στο τέλος δεν έχουμε διαιρέσει το σ
        με το 20.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου