Σάββατο, 17 Ιουλίου 2010

Διορθώστε τα συντακτικά λάθη σε μια διαδικασία

Επισημάνετε τα συντακτικά λάθη της ακόλουθης διαδικασίας
    ΔΙΑΔΙΚΑΣΙΑ ΤΕΛΟΣ [Β[2, 3], Μ, Ν]
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Μ, Ν, Β[2, 3]
    ΣΤΑΘΕΡΕΣ
          Α = 21
    ΑΡΧΗ
          Μ <-- 100
          Ν <-- 0
          ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ Α ΜΕΒΗΜΑ 3
               ΓΙΑ λ ΑΠΟ 4 ΜΕΧΡΙ ΜΕ_ΒΗΜΑ 2
                      Μ <-- Μ-Β[κ, λ]
                      Ν <-- Ν-Β[κ, λ]^2
               ΤΕΛΟΣ_ΓΙΑ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ

Απάντηση

    1. Το όνομα της διαδικασίας είναι λανθασμένο, γιατί το
         ΤΕΛΟΣ είναι δεσμευμένη λέξη.
    2.  Οι παράμετροι της διαδικασίας πρέπει να περικλείονται
         από παρενθέσεις και όχι αγκύλες.
    3.  Στην επικεφαλίδα της διαδικασίας πρέπει να αναγράφεται
         μόνο Β αντί του Β[2, 3].
    4.  Το τμήμα δήλωσης των συμβολικών σταθερών πρέπει να
         προηγείται του τμήματος δήλωσης των μεταβλητών.
    5.  Δεν έχουν δηλωθεί οι μεταβλητές κ, λ στο τμήμα δήλωσης
         των μεταβλητών της διαδικασίας.
    6.  Στην εξωτερική ΓΙΑ η λέξη ΜΕΒΗΜΑ πρέπει να αντικατα-
         σταθεί από τη λέξη ΜΕ_ΒΗΜΑ.
    7.  Στην εσωτερική ΓΙΑ :
         α. το 2Α πρέπει να γίνει 2*Α
         β. το ΤΕΛΟΣΓΙΑ να γίνει ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    8. Η διαδικασία πρέπει να τελειώσει με τη δεσμευμένη
       λέξη ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ αντί της λέξης ΤΕΛΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου