Τετάρτη, 21 Ιουλίου 2010

Άσκηση σε δυσδιάστατο πίνακα

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει 22 ακέραιες τιμές και τις καταχωρεί
    στήλη-στήλη στον ακέραιο πίνακα Γ[2, 11],
β) υπολογίζει και εμφανίζει:
    * το ποσοστό (%) των αρνητικών τιμών,
    * το μέσο όρο των θετικών τιμών.

Λύση

    ΠΡΟΓΡΑΜΜΑ ΑΣΚ
    ΜΕΤΑΒΛΗΤΕΣ
         ΑΚΕΡΑΙΕΣ: Γ[2, 11], λ, μ, Α, Θ, Σ
         ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟΘ, ΠΟΣΑ
    ΑΡΧΗ
         ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 11
            ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 2
                 ΔΙΑΒΑΣΕ Γ[μ, λ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         Α <-- 0
         Θ <-- 0
         Σ <-- 0
         ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 2
            ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 11
                 ΑΝ Γ[μ, λ] < 0 ΤΟΤΕ
                      Α <-- Α+1
                 ΤΕΛΟΣ_ΑΝ
                 ΑΝ Γ[μ, λ] > 0 ΤΟΤΕ
                      Θ <-- Θ+1
                      Σ <-- Σ+Γ[μ, λ]
                 ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΠΟΣΑ <-- 100*Α/22
         ΓΡΑΨΕ 'Ποσοστό αρνητικών :', ΠΟΣΑ, '%'
         ΑΝ Θ > 0 ΤΟΤΕ
               ΜΟΘ <-- Σ/Θ
               ΓΡΑΨΕ 'Μέσος όρος θετικών :', ΜΟΘ
         ΑΛΛΙΩΣ
               ΓΡΑΨΕ 'Δεν υπάρχουν καθόλου θετικές τιμές!'
         ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου