Σάββατο, 31 Ιουλίου 2010

Άσκηση : μετατροπές (Για σε Όσο και Μέχρις_ότου)

Δίνεται το παρακάτω σύνολο εντολών
    Για μ από 100 μέχρι 7 με_βήμα -3
         Για ν από 5.1 μέχρι 89.2 με_βήμα 6.5
             Για ρ από 34 μέχρι 12 με_βήμα -2
                  Εμφάνισε μ+ν+ρ
             Τέλος_επανάληψης
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Ξαναγράψτε το με ισοδύναμο τρόπο αντικαθιστώντας:
α) τις δύο πρώτες Για..από..μέχρι με Όσο..επανάλαβε,
β) την τελευταία Για..από..μέχρι με Μέχρις_ότου

Λύση

     μ <-- 100
     Όσο μ >= 7 επανάλαβε
          ν <-- 5.1
          Όσο ν <= 89.2 επανάλαβε
                ρ <-- 34
                Αρχή_επανάληψης
                     Εμφάνισε μ+ν+ρ
                     ρ <-- ρ-2
                Μέχρις_ότου ρ < 12
                ν <-- ν+6.5
          Τέλος_επανάληψης 
          μ <-- μ-3
     Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου